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RISA TECHNOLOGIES, RISA-3D / RISA Floor 

AUTODESK REVIT STRUCTURE 

WHITE PAPER 

 

Linking your Revit Structure model with 

RISA-3D / RISA Floor 

 

Autodesk

®

 Revit

®

 Structure users can now leverage the full power of their 

analysis software by synchronizing their Revit Structure models with 

RISA-3D and RISA Floor.  While RISA-3D provides a platform to analyze 

any three dimensional structure, RISA Floor provides a complete solution 

for building design. This white paper discusses the methodology for 

exporting a Revit Structure model to the two RISA programs and also for 

updating the Revit Structure model with structural changes. It also 

provides a guide on installing and troubleshooting the round -trip link 

between the two applications.  

 

Why Revit Structure and RISA ? 

 

Imagine relocating a stairwell in an office building – reframing, redesigning, updating 

drawings.  In the past, a task like this would have taken hours.  Likely you would reframe 

plans and hand mark-ups to the draftsman.  While new framing was making its way onto 

the plans, you’d manually update the analytical model, rerun the analysis/design, then 

pour over the results.  With a new design in hand, you’d tag new sizes on the updated 

plans, spending more time than you’d like cutting sections. 

  

With Revit Structure, you’re already ahead of the curve.  Every change – be it new 

framing, sizes, decks, notes – is automatically updated on all drawings in your set.  Even 

sections!  If only the same were true for your analysis software.  With the latest versions 

of RISA programs and Revit Structure it is!  Now you have the full power of RISA 

programs behind every step you make with Revit Structure.  Export the entire Revit 

Structure model, or just a selected subset, to either of the RISA programs.  Perform static 

or dynamic analyses, moving load analyses, vibration loading, live load reduction, 

automatically generate seismic and wind forces, design elements using provisions from 

various countries and tie the results back to your Revit Structure model.  See the 

results...on the drawings and in your project budget. 
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Install the RISA-Revit Structure Link Component 

 

You already have Revit Structure and atleast one RISA program in the office.  In order to 

take full advantage of both programs you’ll need to install the RISA-Revit Structure Link 

Component. 

 

(1) Login to Windows – your account must allow registry access privileges 

 

(2) Exit out of Revit Structure and all RISA programs 

 

(3) Locate the Link Component installation file in one of three locations

1

  

 

 Autodesk

®

 Revit

®

 Structure installation CD 

 Autodesk

®

 Buzzsaw

®

 website 

 RISA Technologies website 

 www.risatech.com/partner/revit_structure.asp 

 

(4) Run the self-executable installation file RISARevitLink5.0.exe 
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The RISA-Revit Structure Link Component installation consists of eight files 

 

 RevitRISAComponent.dll RISA-Revit Structure Link Component 

 

Controls communication between Revit 

Structure and RISA programs. 

 

 RISA_Revit_MapShapes.xml RISA Mapping File 

 

Table listing RISA shape names and their 

Revit Structure equivalents Type names. 

 

 REVIT-RISA Round Trip Data.xls RISA Data Merge Table 

 

Excel spreadsheet listing all data 

parameters that are managed by the link. 

 

 SharedParameterFile.txt Revit Shared Parameter File 

 

Contains internal tracking data used by the 

link. 

 

 Revit_ini.txt Revit INI File Prototype 

 

Sample modification to the Revit.ini file. 

 

 ReadMe.txt RISA-Revit Structure Link info text file 

 

 RISA3D-Revit Component Link.doc  RISA-3D Link Documentation 

 

 RISAFloor-Revit Component Link.doc RISAFloor Link Documentation 
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 For the most current version of the Link Component, visit the RISA Technologies website (www.risatech.com). 

2

 The current Link Component installation file is RISARevitLink4.0.exe, (Version 4.0, Release 2). 
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Each of these files is installed to a new subfolder (RISA Revit Link) within the RISA 

installation directory. 

 

In addition, the installation routine modifies the Revit.ini file to include the RISA-Revit 

Structure Link.  This file is located in the Revit Structure program directory (default 

C:\Program Files\Revit Structure 2008\Program\). Modifying the INI file helps in creating 

the Revit Structure menu commands for the link. An example of this modification is 

contained in the Revit_ini.txt file. 

 

 

Shape Mapping File 

 

Revit Structure and RISA use different data structures to reference the same element in a 

model.  For example, in Revit Structure each particular member is an instance (column at 

grid A-2) of a type (W12x65) within a family (W-Wide Flange-Column).  In RISA, 

however, a particular member is, well, a member (M37) with an associated shape type 

(W12x65).  The RISA Mapping File is the master list that the Link Component uses when 

communicating between one program and the other. 

 

The RISA Mapping File (RISA_Revit_MapShapes.xml) is an Excel based XML file listing 

RISA shape names and their corresponding Revit family names.  The file is formatted 

with three columns separated by several spaces; the first column is the RISA shape 

name, the second column the Revit family type name and the third column is the shape 

type.  Each column is tagged with a field prefix (e.g. [RISA_NAME]) and suffix (e.g. 

[END_RISA_NAME]).  In certain cases, the engineer may want to edit the mapping file to 

add Revit family types and/or RISA shapes.  As long as the shape (family type) and 

material are valid in both Revit Structure and RISA, shapes will map properly – even 

online and custom shapes.  Any shape names that are not explicitly mapped by the files 

will be copied directly using the default name.

3,4

 

 

Troubleshooting Installation 

 

You must install both Revit Structure and RISA-3D v6.0.3 / RISA Floor v3.0 (or later) 

before attempting to install the Link Component.  Version 6.0 users can upgrade to the 

v6.0.1 by downloading the update patch from the RISA website.

5

  The Link Component 

will not work properly with the RISA demonstration software.  Also, you cannot install the 

Link Component while Revit Structure is running, and you must be logged-in with registry 

access. 

 

If for any reason the Link Component fails to install properly, you must perform a 

Windows uninstall. 

 

Remove the Link Component 

 

(1) Exit out of Revit Structure and all RISA programs 

 

(2) Go to Start > Control Panel > Add or Remove Programs 

 

(3) Select RISARevitLink and click Remove 

                                                

3

 Currently, the mapping file lists only typical hot rolled steel shapes, but can be edited to include shapes from 

any material. 

4

 When adding entries to the mapping file, pay close attention to material and structural usage. 

5

 www.risatech.com/s_updates.asp 
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Export Your Revit Structure Model to RISA-3D / RISA Floor 

 

In Revit Structure, to export your model to any RISA program, go to 

 

Tools > External Tools > Send Model to RISA...  

 

 

 

 

 

The Export Window will appear (below) with several options
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 Future supported programs and options not yet available are grayed-out 

 

Figure 1: 

 

External Tools Menu. 

Select a RISA Program 

(default is RISA-3D) 

Create a RISA model on the 

fly or save the model to a file. 

Use only currently selected 

elements in Revit Structure.  

When unchecked, entire 

Revit Structure analytical 

model is exported. (see 

notes below) 

Figure 2: 

 

RISA Link Component 

Export Window. 

Use existing or specify a 

new exchange file name. 

 

 

 

Select existing base file or 

leave blank to create a new 

base file. 
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Here, the engineer selects a RISA program to accept model data from Revit Structure, 

with the option of either exporting directly to RISA or writing to a file.  By default, the Link 

Component will write an exchange and base files in the default RISA directory (typically 

C:\RISA) using the same Revit filename. 

 

Revit Structural Walls are converted directly to individual plates unless the AUTOMESH 

WALLS option is checked.  This option is currently only available for RISA-3D.  When 

selected, walls are submeshed with the RISA-3D AutoMesh tool using beam, column, 

brace, and wall intersections as control points.
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The engineer also has the option of exporting only those elements currently selected in 

the Revit Structure model.  This can be useful when analyzing a substructure such as a 

series of frames or a truss, for instance, without exporting the entire model. 

 

 

IMPORTANT! When working with substructures (or the entire model, for that matter) be 

careful that the Revit Structure model geometry does not change before 

importing updated sizes from the RISA program.  At this time the link 

component does not check for geometric inconsistencies between RISA 

and Revit Structure models.  Methods such as worksets and watch 

monitors in Revit Structure can be helpful in managing these types of 

changes within the Revit Structure model.  

 

 

The engineer can specify a Merge Tolerance and a Footing Tolerance value. Merge 

Tolerance value is provided to take into account the discrepancies while modeling in 

Revit Structure. Any points/ elements/ loads defined within this tolerance limit will be 

snapped to the same location. Footings located within this tolerance distance of a column 

will be snapped back to the column node in RISA.  Footings outside of the tolerance 

distance will be ignored. 

 

In RISA Floor, there is also an option to ‘Redesign Members’. If this option is checked, 

the corresponding design list is automatically selected as the ‘Shape Type’ for each 

column and beam in the structure. This facilitates their design in RISA Floor. If this option 

is not checked, the shape names are explicitly exported to RISA Floor. 

 

Finally, there is an option to export ‘Slabs and Opening Perimeters’. If checked, it 

instructs the link to run around all defined decks and openings in Revit Structure and find 

a closed  polygon of supporting framing around them. If closed framing polygon is found, 

it automatically creates slab perimeters and openings in RISA Floor. 

 

Click “OK”. 

 

The Link Component then creates a RISA exchange file from the current Revit structure 

model.  For larger models, this may take a few moments – you should see a progress bar 

similar to the one below. 

 

 

                                                

7

 See RISA3D-Revit Component Link.doc for limitations. 
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If the WRITE TO FILE option is selected, the engineer will need to manually import the 

exchange file into the RISA program.  To do this in the RISA program, select 

 

File > Import > BIM Exchange File . 

 

 

 

 

After importing the BIM Exchange File, RISA automatically creates a corresponding .r3d / 

.rfl base file (depending on the RISA program) in the working directory.  This base file can 

be saved to any directory location – it’s path is correctly written to the exchange file 

during BIM Exchange File export (see next section).  

Figure 3: 

 

Link Component 

Export Progress 

Window. 

Figure 4: 

 

File Import Menu. 
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Supported Elements 

 

RISA 3D 

 

Grid Lines Both horizontal and vertical grid lines and labels are 

supported.  While grid lines in Revit Structure have 

individual start/end locations, grid lines in RISA-3D span 

to the furthest intersecting grid line in each direction. 

 

Columns, Beams, Braces Family instances with column, beam, and brace 

structural usage parameters are supported.  Other 

supported properties are: rotate angle, material type, 

family type name, start/end release codes, structural 

type, and element ID.  RISA-3D Redesign Lists are set 

to “None” for Revit-native members.  Rigid Links 

between columns and beams are supported.  The Link 

Component has been updated to match material type to 

shape, and will now import physical material properties. 

 

Structural Walls All structural walls except “Non_Bearing” are supported 

and mapped to 4-node plates in RISA-3D.  Structural 

wall thickness maps to plate thickness, and material type 

and properties are also supported. Doors and windows 

are not supported at this time. 

 

 Revit Structure structural walls map to one plate each in 

RISA-3D unless the AUTOMESH WALLS option is 

selected.  When selected, RISA-3D automatically 

meshes each wall according to the control points of any 

intersecting geometry (beams, columns, braces, walls). 

 

Footings Family instances with the Footing-Rectangular structural 

usage parameter are supported, including length, width, 

and thickness.  Only footings attached to the 

superstructure at a logical RISA-3D joint (base of 

column, beam, brace; wall corner) – or within the user-

defined Footing Tolerance – will be recognized by the 

Link Component.  Physical material properties, rebar 

data, and rotation angle are not supported at this time.

8

 

 

Materials Steel, Concrete, and Wood (Revit) materials are 

correctly mapped into RISA-3D.  Any material 

associated with a Revit Wall is converted into an 

equivalent RISA-3D General Material. 

 

Point Loads Point Loads map to RISA-3D joint or member point loads 

based on location.  Point Loads not located on a joint or 

member are ignored.  The local coordinate system flag 

for point loads is ignored. 

 

Line Loads Line Loads map to RISA-3D member distributed loads.  

Any portion of a Line Load co-incident with a member 

will be translated.  Line Loads may span multiple 

                                                

8

 Only licensed RISA-3D users who have RISAFoot will be able to access this feature. 
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members and start/end independently of individual 

members.  The local coordinate system flag for line 

loads is ignored. 

 

Area Loads Only Revit Area Loads with 3 or 4 vertices are converted 

to corresponding RISA-3D member area loads – multi-

sided Area Loads, Area Loads with Host having more 

than 4 sides are not translated.  Area Loads flagged as 

projected will map to projected area loads in RISA-3D.  

The local coordinate system flag for area loads is 

ignored.  Open Structure Area Loads are not yet 

supported by Revit Structure. 

 

Load Cases Load Cases map directly to RISA-3D Basic Load Cases.  

Load Case labels are used to filter Revit Structure loads 

into the proper RISA-3D basic load case.  Load Case 

Natures are ignored. 

 

Load Combinations Load Combinations map directly to RISA-3D Load 

Combinations, including labels, references, and factors.  

Load Combination type maps to the RISA-3D solve or 

envelope flag.  Load Combination state maps to the 

RISA-3D service flag.  All materials are flagged for 

design in each Load Combination. 

 

Boundary Conditions Point Boundary Conditions are supported for Revit X/Y/Z 

translation and rotation.  Point springs along with their 

modulus are also supported.  Pinned Boundary 

Conditions are assigned to the bottom of all column 

stacks and walls where no beam, column, or brace falls 

below it. 

 

 

RISA Floor 

 

Floor/ Level Information Levels are brought in as Floors in RISA Floor. Level 

name and elevation are the properties that are 

supported for various Levels. 

 

Grid Lines Both horizontal and vertical grid lines and labels are 

supported.  While grid lines in Revit Structure have 

individual start/end locations, grid lines in RISA Floor 

span to the furthest intersecting grid line in each 

direction. 

  

Beams, Columns, and Braces Family instances with structural usages of column, 

beam, and braces are supported.  While Columns and 

Beams are brought in as RISA Floor elements, Braces 

are brought in as supplemental RISA-3D elements. 

The following properties are supported; rotate angle, 

material type, family type name, start release code, end 

release code, structural type, and element ID.  Material 

type and physical material properties are also supported.  

Uniform studs and camber information is also brought 

into RISA Floor for beam elements.  
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Cantilever Beams If either the “Moment Connection Start” or “Moment 

Connection End” fields of a beam are set to “Cantilever 

Moment”, then the beam would be brought in as a 

Cantilever in RISA Floor.  

 

Physical/Multi-Level Columns If a column spans along multiple levels in Revit 

Structure, it will be exported as a physical column to 

RISA Floor. In RISA Floor, all floors/ levels through 

which this column passes will have a corresponding 

entry for this column, and a corresponding column stack 

will be added to the RISA Floor model.  

 

Splices The offset associated with the actual top level of the 

column is read and converted appropriately as splice 

level elevation for relevant columns within the column 

stack. The splice type is also read in for Steel members.  

Actual base level offsets are read for only the 

bottommost columns in each column stack. The base 

offset for the bottommost columns can be provided as a 

positive distance from any level. This provides flexibility 

to model structures on uneven terrains like in hilly areas.  

The link will also automatically create splices if the 

following properties differ for columns in the same 

column stack: Shape Name, Material Type, Material 

Offset, Function and/or rotation angle. 

  

Walls Wall Elements are supported for RISA Floor. Wall 

Thickness and function are the properties that are 

supported. Material Type and physical material 

properties are also supported.  

 

Gravity / Lateral Elements If the ‘Analyze As’ field of a beam or column is set to 

“Lateral”, then it would be brought in as a Lateral 

Element. If set to “Gravity”, it would be brought in as a 

gravity member. Braces are always brought in as lateral 

elements. All columns sharing a node with a lateral 

beam or lateral wall are automatically converted to 

Lateral. Along with this, all column stacks that have 

bracings in the bay between them are also automatically 

converted to lateral. Any element having a lateral loading 

will also be converted to lateral. 

 If the ‘Structural Usage’ flag is set to 'Shear' or 

'Combined' for Walls, then it is exported as a lateral 

element into RISA Floor. In all other cases, walls are 

exported as Gravity elements.  

 

Area Load Definition  All area loads along with their corresponding magnitudes 

have a corresponding entry under the ‘Area Load 

Definitions’ in RISA Floor, 

 

Deck Definitions  Slabs/Deck properties are brought in as ‘Deck 

Definitions’ in RISA Floor. The name of the deck, its 

thickness, deck direction, concrete strength, weight of 

concrete and Elastic modulus are brought into RISA 

Floor from Revit Structure. 
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Materials Steel, Concrete, and Wood (Revit) materials are 

correctly mapped into RISA-3D.  Any material 

associated with a Revit Wall is converted into an 

equivalent RISA-3D General Material. 

 

Load Combinations  Load Combinations are directly translated into RISA 

Floor Load Combinations.  Load Combination Labels, 

Load Case references and Load Case factors is being 

supported. The combination state is also brought over as 

the RISA Floor service flag. Load Cases are mapped in 

accordance with the corresponding category from REVIT 

to RISA Floor  

 

Point Loads  REVIT point loads are translated into RISA Floor point 

loads. Point loads can be placed anywhere on the 

structure, and it is not necessary for these loads to lie on 

top of any element.  

 

Line Loads REVIT line loads are brought over as RISA Floor line 

loads. Line loads can be placed anywhere on the 

structure, and it is not necessary for these loads to 

coincide with any element.   

 

Area Loads REVIT area loads are brought into RISA Floor. Polygon 

area loads and multi-loop area loads are supported in 

RISA Floor. The user can define the area load edges 

anywhere on the structure and it are not mandatory for 

these loads to coincide with any elements on the 

structure. 

 

Decks REVIT Decks/slabs are brought in as RISA-Floor Decks. 

Polygon decks/slabs are supported in RISA-Floor. The 

user can define the decks/slabs anywhere on the 

structure and it is not mandatory for them to coincide 

with any element on the structure. At solution time, 

decks in RISA Floor will be automatically clipped to lie 

within the defined slab perimeters. 

 

Slab Perimeters / Openings Openings and slab perimeters are automatically created 

by the Component Link if a closed framing polygon is 

found around the defined edges in Revit Structure. 

Perpendicular distance from the mid point of each 

opening edge created by the link to the actual edge in 

Revit Structure gives the value of overhang for that 

particular opening edge.  
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Physical vs. Analytical Models 

 

Remember, in Revit Structure there are two primary models: the physical model and its 

analytical counterpart.  When you export your Revit Structure model to RISA, the Link 

Component reads the analytical model (including its connectivity) when creating the 

corresponding structure in RISA programs.  For this reason it’s important to maintain 

continuity in the Revit analytical model.  If the analytical threads of physical elements are 

not connected, this can lead to discontinuities and instabilities in the RISA model. Part of 

this problem can be fixed by using a large value of ‘Merge Tolerance’. 

 

 

Exchange File vs. Base File 

 

The RISA Revit Link Component v4.0 and later uses a split file system to manage the 

exchange of Revit and RISA native information.  An exchange file (.exc) is used to pass 

information between Revit and RISA, and vice versa.  The exchange file is simply a 

smaller RISA file containing only data being passed between the two programs.   Since 

the RISA model contains certain parameters that are not part of a Revit model (e.g. 

Design Rules, braced lengths), RISA creates a base file – a full RISA (.r3d/.rfl) file – in 

which is stores this additional data. 

 

As information is passed between the programs, both RISA and the Link Component 

compare information in the exchange file with the base file to correctly track changes and 

maintain data continuity.  Initially, Revit creates an exchange file that is read into the 

RISA program.  As new information is added to the RISA model, it is stored in the 

corresponding base file.  A new exchange file is created and passed to Revit, thereby 

updating the Revit model.  After changes are made in Revit, another exchange file  is 

created.  As this exchange file is imported into RISA, it is merged with the base file 

created earlier, retaining RISA-specific data created earlier.  This process is illustrated in 

Figure 5, below.

9

 

 

 

                                                

9

 Refer to the REVIT-RISA Round Trip Data.xls spreadsheet for specific details on which parameters are 

preserved, overwritten, and merged. 

Figure 5: 

 

Exchange File 

Process. 
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BIM 

 

RISA 
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.rfl 

 

BIM 
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Base File 

 

Exchange File 
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Import Changes from RISA-3D / RISA Floor to Revit 

Structure 

 

Be sure to save your work in the RISA program.  Performing Save or Save As… will save 

your changes to the base file, but will not create an exchange file.  To update the existing 

exchange file (or create a new one), you must export a BIM Exchange File. 

To do this in the RISA program, select 

 

File > Export > BIM Exchange File 

 

 

 

 

 

If the exchange file was created successfully, an export confirmation dialog appears. 

 

 

 

 

Note:  The default BIM import/export directory can be set using the Tools > 

Preferences menu of the RISA program. 

 

Go back to Revit Structure and import your changes from the RISA program. 

 

Tools > External Tools > Update Model from RISA... 

 

 

 

Figure 8: 

 

External Tools Menu. 

Figure 6: 

 

File Export Menu. 

Figure 7: 

 

Export Confirmation 

Dialog. 
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The Update From RISA Window will appear (below) with several options 

 

 

 

 

 

Click “OK”. 

 

The Component Link scans the RISA file and updates Revit Structure family type names 

for supported elements.  As before during Export, a progress bar will appear while 

importing larger models. 

 

 

 

 

Figure 9: 

 

RISA Link Component 

Import Window. 

Figure 10: 

 

Link Component Import 

Progress Window. 

Select a RISA Program 

(default is RISA-3D) 

Select RISA elements to be 

imported back to Revit 

Structure.  Select which 

Revit Families to scan 

during the Auto-Load 

process. 

Specify the target RISA 

exchange file. 

 

 

 

If the exchange file has a 

corresponding base file, 

then it would automatically 

be shown in this text box. 
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Once the Component Link finishes importing, the Revit Structure model will be updated. 

 

Supported Elements 

 

Columns, Beams, Braces Resized RISA members are mapped back to Revit 

Structure via the mapping file and family type names are 

updated.  Shape names that appear in both the 

Structural Column and Structural Beam families are 

identified by the presence of “Column” in the Structural 

Column family name and “Framing” in the Structural 

Framing family name, respectively.  The latest version of 

the Component Link supports AutoLoading of Revit 

families during import. 

 

 

IMPORTANT! Revit Structure 4 users must use the v4.0 Component Link and are 

required to pre-load all structural family types (shapes) in the Revit 

Structure project before attempting to redesign in RISA. 

 

 

What’s New in the Component Link v5.5 

 

 Ability to read curved beams. 

 Ability to read in-place families. 

 Multi-level Walls as supported in RISA Floor. 

 Bug Fix for Metric Unit Shape Conversion. 

 Log File added to Export / Import Operation. 

 

What’s New in the Component Link v5.0 

 

 New Excel based XML Mapping File 

 Ability to Export Negative Loads to RISA Floor. 

 Ability to Export ‘Analyze As’ Flag to RISA 3D. 

 

What’s New in the Component Link v4.0 

 

 New Exchange File Method 

– allows continuity of data throughout the exchange cycle (round trip) 

– only exchange file (.exc) is transferred between programs 

– base file (.r3d / .rfl) retains additional data not sent to Revit 

  (i.e. K, Lb, Design Rules, etc.) 

– user can create new members in RISA that are stored in base file but are not 

read into Revit 

 AutoLoad Families – automatically loads Revit families on import from RISA 

 AutoMesh Walls – uses the RISA-3D AutoMesher to submesh Revit walls 

 Vertical Axis –rotated automatically if user changes default orientation 

 Physical Materials and properties – automatically created for all elements 

 Physical Columns – supports RISAFloor physical columns and splices 
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Troubleshooting 

 

Some common issues when using the RISA-Revit Structure Link Component. 

 

How do I export a RISA (3D or Floor) model to Revit?  

 

The current version of the link does not support creating a model in RISA and 

then exporting to Revit – the model must first be created in Revit.  Revit Structure 

4 Release 2 should support this workflow. 

 

I go to TOOLS > EXTERNAL TOOLS in Revit Structure, and the option to “Send 

Model to RISA…” or “Update Model from RISA…” is not available.  

 

You must install the Revit Structure Component Link.  Be sure to exit both RISA 

and Revit before attempting to install the link. 

 

The Tools > External Tools menu is grayed-out. 

 

Be sure that the model view in Revit Structure is selected.  Do this by clicking on 

the model view window.  Go to the Tools menu and you should see that the 

External Tools submenu is available. 

 

After importing my design changes from RISA-3D to Revit Structure, some member 

shapes are not updated. 

 

Be sure to save the file in RISA-3D before importing back to Revit Structure.  If 

you have saved the file under a different file nam e, be sure the SELECT FILE TO 

IMPORT box is checked in the import window and specify the file.  If you are 

using the Component Link 3.0, pre-load necessary families and types before 

importing back to Revit Structure – it does not automatically load new shapes.  

  

I notice that my walls are not connected or that beams do not connect with 

columns when exporting to RISA-3D. 

  

RISA-3D scans the analytical portion of the Revit Structure model.  Ensure 

proper connectivity of the analytical model in Revit Structure – vertical alignment 

of walls, column-to-beam connections (specifically, rigid links).  When properly 

defined, Revit Structure automatically maintains this connectivity.

10

 

 

When I export from Revit to RISA-3D my framing is OK but I lose my area loads!  

 

RISA-3D only supports 3- and 4-sided area loads.  Revit allows directly defined 

and hosted area loads that can have many sides.  Redefine your Revit area 

loads with a maximum of 4 sides. 

 

When I import from RISA (3D or Floor) my framing sizes aren’t updated!  

 

Be sure that you have first exported a BIM Exchange File from your redesigned 

RISA model.  Save the RISA model, then go to File > Export > BIM Exchange 

File.  If you are using the Component Link 3.0, you must first load the 

corresponding family types (i.e. W14X22, W16X26, etc…) for your new designs. 
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 For more info on rigid links, see the Revit Structure User’s Guide 
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I’m using the Component Link 3.0 and have pre-loaded all necessary family types 

into my Revit model, but sizes still aren’t updating! 

 

Revit supports both ‘Architectural’ and ‘Structural’ beams/columns/walls.  If you 

received a model from the architect these members may not have their usage set 

to ‘Structural’ – only ‘Structural’ shapes are exchanged with RISA.  You can see 

this by right-clicking on a member and selecting ‘Properties…”. 

 

Also, the Component link does not support custom families.  If you are trying to 

exchange custom families, they will not transfer.  An exception is for built-up 

sections using the shape mapping file. 

 

After installing the Component Link I get a warning message when opening Revit: 

“.NET 2.0 must be installed to take advantage of the associated external 

commands” or similar. 

 

Our latest Component Link uses Microsoft .NET commands to interface with the 

Revit API.  A simple Windows Update should offer to install .NET 2.0. 

 

When I export my model from Revit to RISA, I have lots of instabilities.  

 

Although you can assign end releases in Revit, Revit itself does not perform a 

stability check.  You will need to assign the correct end releases on the Revit 

side to maintain a stable model for each roundtrip. 

 

When I export my model from Revit to RISA, I get a version error.  

 

The Component Link 2008 will only write a RISA-3D v6.0.1 / RISA Floor v3.0 file 

format (or later).  Contact RISA Technologies to obtain a compatible version. 

 

Recommended System Requirements 

 

 1 GB RAM or better 

 Pentium 4, 1.5GHz or better 

 

 

Resources 

 

RISA Technologies  www.risatech.com/partner/revit_structure.asp 

    support@risatech.com 

 

Autodesk   www.autodesk.com/structure 
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